Routing Information Protocol. (RIP)

Routing Data Project (RIP) can be a standards-based, distance-vector, indoor trip project (IGP) as used by routers to exchange routing data. TEAR employs jump count to look for the very best path involving a couple of spots. Go count can be the amount of routers this packet have to move through until finally the item grows to this getaway network. The most allowed number of hops a packet can easily navigate in an IP network utilizing TEAR can be 15 hops.
they have a highest allowed jump count involving 15 automagically, which means that of sixteen can be regarded unreachable. TEAR successful inside small systems, however it is unproductive with huge systems using slow-moving WAN hyperlinks or maybe with systems using quite a few routers installed.
In the TEAR network, each and every router broadcasts their overall TEAR desk in order to their border routers each 30 mere seconds. Each time a router will get a the next door neighbor's TEAR desk, the item employs the info presented in order to update its very own routing desk after which it transmits this updated desk in order to their neighbours.

Variances involving RIP-v1 or  RIP-v2

RIPv1
A classful project, broadcasts updates each 30 mere seconds, hold-down interval one hundred and eighty mere seconds. Go count can be metric (Maximum 15).
TEAR supports around six equal-cost pathways to some individual getaway, where most six pathways could be slipped into this routing desk along with the router can easily load-balance over these people. The actual default will be a number of pathways, however this is often increased up to a highest involving six. Keep in mind that an equal-cost path can be in which the jump count worth will be the very same. TEAR will not likely load-balance over unequal-cost pathways

RIPv2
RIPv2 employs multicasts, edition 1 use broadcasts,
RIPv2 supports brought about updates—when a big difference comes about, a RIPv2 router will certainly quickly propagate their routing data in order to their related neighbours.
RIPv2 can be a classless project. RIPv2 supports variable-length subnet hiding (VLSM)
RIPv2 supports authentication. You can prohibit just what routers you intend to be involved in RIPv2. This really is completed by using a hashed private data worth.

RIP Timers
TEAR employs four kinds of timers to manage the performance:
Option up-date timer
Pieces this phase (typically 40 seconds) concerning routine direction-finding messages in which the router directs an entire content associated with the direction-finding desk away to all or any neighbours.
Option broken timer
Determines just how long that has got to elapse (180 seconds) prior to the router decides which a course has become broken. It will go to this realization in the event the idea hasn’t seen almost any messages about a specific course to the period. Any time you do, this router will send out messages to all or any the neighbours letting them understand that this course is broken.
Holddown timer
This specific models how much moment where direction-finding details is suppressed. Paths will enter this holddown express while the up-date package is received in which advised this course is unreachable. This specific proceeds often until finally the up-date package is received with a better metric or prior to the holddown timer expires. The actual default is one hundred eighty seconds.
Option eliminate timer
Pieces time concerning the course getting broken and its removal from the direction-finding desk (240 seconds). Ahead of it is taken off this desk, this router notifies the neighbours of the route's upcoming failing. The value in the course broken timer need to be less than in which in the course eliminate timer. This gives this router enough time to express to the neighbours about the broken course prior to nearby direction-finding desk is up to date.

Grab Redirecting options.
We will use two router and four subnet. Create a topology as shown in figure on packet tracer.
basic rip routing
RouterFastEthernet 0/0FastEthernet 0/1Serial 0/0/0
R110.0.0.120.0.0.150.0.0.1
R230.0.0.140.0.0.150.0.0.2
PCIP AddressPCIP Address
PC020.0.0.2PC120.0.0.3
PC240.0.0.2PC340.0.0.3
PC410.0.0.2PC510.0.0.3
PC630.0.0.2PC730.0.0.3
Assign ip address to PC. Select pc and double click on it. select ip configurations from desktop tab and set ip address given as in table.
To configure router double click on it and select CLI.To configure this topology use this step by step guide.

(1841Router0) Hostname R1

To configure and enable rip routing on R1 follow these commands exactly.
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R1
R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config-if)#exit
R1(config)#interface fastethernet 0/1
R1(config-if)#ip address 20.0.0.1 255.0.0.0
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
R1(config-if)#exit
R1(config)#interface serial 0/0/0
R1(config-if)#ip address 50.0.0.1 255.0.0.0
R1(config-if)#clock rate 64000
R1(config-if)#bandwidth 64
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
R1(config-if)#exit
R1(config)#router rip
R1(config-router)#network 10.0.0.0
R1(config-router)#network 20.0.0.0
R1(config-router)#network 50.0.0.0

(2811Router1) Hostname R2

To configure and enable rip routing on R2 follow these commands exactly.
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R2
R2(config)#interface fastethernet 0/0
R2(config-if)#ip address 30.0.0.1 255.0.0.0
R2(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0,
 changed state to up
R2(config-if)#exit
R2(config)#interface fastethernet 0/1
R2(config-if)#ip address 40.0.0.1 255.0.0.0
R2(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1,
 changed state to up
R2(config-if)#exit
R2(config)#interface serial 0/0/0
R2(config-if)#ip address 50.0.0.2 255.0.0.0
R2(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
R2(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0,
 changed state to up
R2(config-if)#exit
R2(config)#router rip
R2(config-router)#network 30.0.0.0
R2(config-router)#network 40.0.0.0
R2(config-router)#network 50.0.0.0
R2(config-router)#exit
To test rip routing do ping from pc0 to all pc and vice versa. If you get replay then you have successfully configured rip routing but if you did not get replay double check this configuration and try to troubleshoot. I have uploaded a configured and tested topology in case you are unable to locate the problem spot then download this configuration file. And try to find out where have you committed mistake


SHARE THIS

Author:

Previous Post
Next Post